Via Intersight it is possible to install HyperFlex and HyperFlex Edge clusters very easy. Now you can also upgrade the ESXi Hypervisor of the HyperFlex cluster via Intersight.

Upgrade Hypervisor

Go to Intersight.com and select HyperFlex Clusters.

You will see your HX Clusters and on the right you will see 3 dots. When you click on those, you will see:

Upgrade via Intersight

And select Upgrade.

When you receive the following error:

Upgrade only when installed via Intersight

This means you imported a HyperFlex Cluster that is installed via HyperFlex Connect. Right now you can only upgrade when the HyperFlex cluster is installed via Intersight.

 

Selecting HXDP works now (may 2020) only with HyperFlex Edge Clusters. NOT with HX clusters which are connected to Fabric Interconnects!
Check out the What is New page of Intersight  or the Features page of Intersight to see when a upgrade is possible via Intersight of HXDP.

 

To start select the Expert Mode [1] and select Upgrade Hypervisor [2].

Via the drop down menu, you can select the ESXi version [3]

In this example the ESXi will be upgraded from 6.5u3 to 6.7u3.

Upgrade via Intersight

 

The system will first run some pre-upgrade Validation checks.

Upgrade Validations

 

If something is failing, you will see a red bar at the top of the page and you will have to resolve this problem.

HX not healthy

 

When the HX Cluster is Healthy again, you can restart it again.

Here you can see I can upgrade the Hypervisor of the HX Cluster.

lets upgrade hypervisor

 

You will see a summary.

to which hypervisor

 

Lets start

Hit the Upgrade button and the hypervisor on the nodes get the new version of ESXi.

Upgrade hypervisor via intersight

 

As you can see, it is now in progress. You don’t have to do a thing.

 

 

The HyperFlex cluster contains of 4 nodes and the upgrade process of those nodes is in progress.

 

You can see the details of what is going on.

 

During the Pre-Upgrade phase, Intersight shows there is a problem and the process will stop.

In my case I didn’t do the post_install script after the installation and I had to configure vMotion interfaces.

 

Of course this was a build in error, just in case if you hit this 🙂

 

I solved the problem and the started it again.

 

 

And this result is what I was waiting for: SUCCESS! 🙂

 

You can verify the hypervisor version at vCenter

In Intersight

And via HyperFlex Connect.

 

 

 

 

 

Please follow and like us:
onpost_follow
Tweet
Share